Tutorial: Meshing of a simple centrifugal pump with ANSYS ICEM 16.2

Aljaž Škerlavaj¹, Enrico Nobile²
¹KOLEKTOR Turboinštitut, Ljubljana
²DIA - Dipartimento di Ingegneria e Architettura
Università degli Studi di Trieste

January 2018
1 Introduction

This document is a tutorial that describes procedure of creation of structured and unstructured computational meshes for a simple centrifugal pump. Meshing is done with ANSYS ICEM 16.2. Such meshes can then be used for CFD (Computational Fluid Dynamics) simulation.

The geometry of the pump is based on the description in [1] and is provided in three .stp files.

The meshes created with this tutorial are rather coarse for two reasons. The main goal was to describe the process itself. Secondly, depending upon the ANSYS license, the user might be limited to run only CFD cases with up to 512,000 cells/elements. Of course, the user can choose to make finer meshes, which would result in improved accuracy of CFD simulations.

The authors of this tutorial are not related to ANSYS company in any way.

2 Case description

Centrifugal pumps are widely used in engineering applications. Therefore, the current document instructs to create computational grids (meshes) for a given geometry and to prepare a setup for the CFD simulation.

The presented case is a very simple shrouded centrifugal pump impeller (Fig. 1), the (scaled) Grundfos CR4, with medium specific speed. The PhD thesis by Pedersen [1] includes experimental and CFD results for the pump. The experiments were performed for a transparent impeller (produced in perspex) by Particle Image Velocimetry (PIV) (Fig. 2) and Laser Doppler Velocimetry (LDV) techniques. The CFD analysis was performed with Large Eddy Simulation (LES).

3 Geometry

The provided impeller geometry is an approximation of the geometrical data (Table 1) provided in [1].

<table>
<thead>
<tr>
<th>Basic data of the impeller.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inlet diameter $D_1$</td>
</tr>
<tr>
<td>Outlet diameter $D_2$</td>
</tr>
<tr>
<td>Inlet height $b_1$</td>
</tr>
<tr>
<td>Outlet height $b_2$</td>
</tr>
<tr>
<td>Number of blades $Z_1$</td>
</tr>
<tr>
<td>Blade thickness $t_i$</td>
</tr>
<tr>
<td>Inlet blade angle $\beta_1$</td>
</tr>
<tr>
<td>Outlet blade angle $\beta_2$</td>
</tr>
</tbody>
</table>

Table 1: Impeller characteristics [1].
Figure 1: Geometry of the pump impeller [1]

Figure 2: Details of the PIV setup [1].
Usually, the CFD computational domain is not limited only to the blade section, as presented in Fig. 1, but includes also an inlet and an outlet part/domain. The inlet extension provides more realistic inlet conditions, whereas the outlet one provides more realistic conditions (velocity vectors) at the outlet from the impeller.

Therefore, three geometry files are provided, corresponding to three computational 'domains’ of CFD simulations: inlet, impeller and outlet domain. In Table 2 the relation of filenames and computational domains is provided. The whole geometry is provided for a 60° section (1/Z₁ of the full circle).

<table>
<thead>
<tr>
<th>Filename</th>
<th>Part No. in Fig. 3</th>
<th>Computational domain</th>
</tr>
</thead>
<tbody>
<tr>
<td>geometry_inlet3.stp</td>
<td>1</td>
<td>inlet</td>
</tr>
<tr>
<td>geometry_impeller3.agdb</td>
<td>2</td>
<td>impeller</td>
</tr>
<tr>
<td>geometry_outlet3.stp</td>
<td>3</td>
<td>outlet</td>
</tr>
</tbody>
</table>

Table 2: Geometry filenames and computational domains.

Figure 3: Geometry, specified by three geometry files

4 Computational grids - ANSYS ICEM

This section describes how to create computational grids for all three parts (provided by three geometry files) in ANSYS ICEM. It is suggested to put each geometry file in a separate file directory.

A. Škerlavaj, E. Nobile - January 2018
4.1 Computational grid 1

Start ANSYS ICEM by clicking All programs → ANSYS 16.2 → Meshing → ICEM CFD 16.2. Set the working directory of the first file (geometry_inlet.stp): File → Change Working Dir…

Open the geometry file of part 1: Click File → Import Geometry → Legacy → STEP/IGES, select a file, click Open, then click Apply in the window presented in Fig. 4.

![Import Geometry From Step or IGES](image)

Figure 4: Importing the geometry file.

The geometry is imported. Save the project to select project’s name: File → Save Project As..., write mesh_inlet.prj and click Save.

In the window that represents geometry the left mouse button (LMB) rotates the geometry, the central mouse button (CMB) moves geometry and the right mouse button (RMB) scales up/down the geometry. In the left region of the screen a Display Tree (Fig. 5) is shown, which can be used for control of display in the main window. It is possible to click on the + sign to expand the tree.

![Display Tree](image)

Figure 5: Display Tree.

The imported part represents an inlet part above the impeller in Fig. 2. From the figure it can be concluded that side walls of the inlet geometry do not rotate.

The first step is to set the correct units and size. Click (LMB) Settings → Model/Units. Set the units to Milimeters and click OK. The geometry size should be increased by 1000 times. In the Main Toolbar click Geometry → Transform Geometry: . Use the settings according to Fig. 6 and click . Enable selection of points, curves, surfaces and bodies in the
floating menu (choices in the menu should be enabled). Then press "a" on the keyboard (shortcut for "select all") and click Apply. Click Fit Window icon to fit the geometry in the screen window.

![Transformation Tools](image)

**Figure 6:** Scaling the geometry by a factor of 1000.

The next step is the creation of the "parts" in the Display Tree, which can later represent selectable surface parts of the meshes in e.g. ANSYS CFX Pre. CFX Pre or similar software is used to set up the CFD simulation by prescribing boundary conditions, initial conditions, numerical models, etc. Another advantage of creating "parts" is grouping surfaces with equal size of mesh elements (in case of unstructured grids).

Five parts will be created in the Display Tree of the mesh_inlet.prj project: geom1_in, geom1_out, geom1_walls, geom1_per1 and geom1_per2 (the 'geom1' label was used to represent the inlet part/domain of the whole case).

Rotate the geometry so that Z axis is pointing upward, turn on surfaces in the Display Tree and click on solid simple display icon in the Main Menu. The result is presented in Fig. 7.

To create a part (containing a surface) the following procedure can be used:

- Right-click on Parts, then left-click on Create Part
- Enter(write) the part’s name in the top field
- Click on icon next to Create Part by Selection. The most important functionality of the pop-up window is to toggle on/off selection of points, curves, surfaces and bodies by clicking the four icons. Turn on only the selection of surfaces:

![Create Part by Selection](image)
4.1 Computational grid 1

Figure 7: The geometry of the first domain (inlet domain) before creation of parts.

- Pick-up the desired surface(s) by left-clicking (LC) on surface(s), then finish with a middle-button-click (MC). Before finishing it is possible to undo the picking-up actions (in a reverse direction) by using a right-mouse button (RC). During the pick-up process it is possible to rotate/move the geometry by pressing $F9$ button (and re-pressing to re-enter the pick-up process).

- MC again to finish the selection process.

- A new part appears in the Display Tree and the part’s surface(s) change its colour.

By using the described procedure create the five parts. The part geom1_in includes the inlet surface (with the highest $Z$ value) - the surface at the top in Fig. 7. The part geom1_out includes the outlet surface (with the lowest $Z$ value). The part geom1_walls includes the annular section/surface. There should be two periodic parts. Suppose that index Per1 of the periodic parts is on the left side of index 3 in Fig. 3 (for geometry 3), whereas index Per2 is on the right side of index 3. Therefore, the part geom1_per1 is the visible vertical surface in Fig. 7, whereas the part geom1_per2 is the hidden vertical surface in Fig. 7.

In the Main Toolbar click $\text{Geometry} \rightarrow \text{Create Body}$.

Turn on points visibility and turn off visibility of surfaces in the Display Tree. Create a body (part) named BODY_INLET by using $\text{Centroid of two points}$ and picking up two points (e.g., as in Fig. 8). MC twice. Check that the centroid (body) point lies within the geometry, bounded by surfaces (rotate the geometry to check it).

In the Main Toolbar click $\text{Mesh} \rightarrow \text{Global Mesh Setup}$.

Set the global mesh parameters according to Fig. 9 (Max element size=4.0, Prism initial height=0.1, ratio=1.2, layers=10, Rotational period. axis = 0 0 1, angle=60). Click $\text{Apply}$ in each of the three windows. It should be noted that in some cases (complex ones) the creation of prism layers may fail with the latter setting. In such cases it is better to set only two parameters for prism elements (thus leaving the total prism height 'floating'). For instance, set only the ratio with e.g. 7 layers, and later subdivide and rearrange the layers (as it will be done for the blade mesh).
4.1 Computational grid 1

Figure 8: Create Body: selection of two points.

Figure 9: Global mesh setup.
Besides setting the global parameters it is possible to set local parameters for specific parts. In the Main Toolbar click \textit{Mesh $\rightarrow$ Part Mesh Setup}: \includegraphics[width=0.4\textwidth]{part-mesh-setup.png}. A pop-up window appears. Choose parameters according to Fig. 10 (BODY\_INLET part will have a hexa core mesh, max. size=4, prism layers will be located at part \textsc{GEOM1\_WALLS}). Instead of putting 4 to the \textit{max size} it would be possible to leave the setting as 0, because of the previously defined global parameters. Prism elements are needed only at walls. The hexa-core mesh converts tetrahedral elements to hexagonal elements, thus reducing number of elements (decreased elements vs. nodes ratio). To finish, press \textit{Apply}, then \textit{Dismiss}.

![Part mesh setup](part-mesh-setup.png)

Figure 10: Part mesh setup.

After defining the mesh parameters it is time to create the mesh. In the Main Toolbar click \textit{Mesh $\rightarrow$ Compute Mesh}: \includegraphics[width=0.4\textwidth]{compute-mesh.png}. In the Compute Mesh window turn on creation of prism layers and mesh hexa-core after the tetra meshing (Fig. 11). It would be also possible to create prism layers and hexa core in a separate meshing process. This can be useful for complicated geometries, where it is better to create a high-quality tetra mesh first (quality above 0.2 or 0.3). Press \textit{Compute}.

![Compute Mesh window](compute-mesh.png)

Figure 11: Compute Mesh window.

To view the mesh (if it is not visible) turn on Shells in Mesh tree of the Display Tree, as...
well as surface parts, left-click in the Main Toolbar, then click Fit Window icon in the Main Toolbar. The mesh is presented in Fig. 12.

Check the mesh for errors. Click Edit Mesh → Check Mesh ( ). Click Apply. A pop-up window appears. Select the two periodic parts and click Accept. Confirm the deletion of unconnected vertices (click Yes).

Check the quality of the mesh. Click Edit Mesh → Display Mesh Quality ( ). The mesh quality is just above 0.2.

Improve the mesh quality. Click Edit Mesh → Smooth Mesh Globally ( ). Set the smoothing parameters according to Fig. 13. Click Apply. The new quality is above 0.25. If it was smaller, the smoothing would be repeated with quality limit set to 0.2 and all previously ‘Frozen’ types of meshes set to ‘Smooth’.

Repeat the previously described Check Mesh step.

Click File → Save Project.

If the user is using ANSYS CFX for CFD simulations, the mesh has to be exported to a .cfx5 file format. Click Output → Select solver ( ) and set the field Output solver to ANSYS CFX. Click Apply. Then click Output → Write input ( ). Confirm saving the project. Click Done in another pop-up window. Wait until you see ‘Done with translation’ message in the Message window. The mesh is exported. Now close the project (you can as well save it).

4.2 Computational grid 2

Start ANSYS ICEM by clicking All programs → ANSYS 16.2 → Meshing → ICEM CFD 16.2.

Set the working directory of the second geometry file (geometry_impeller3.agdb): File →
10

4.2 Computational grid

Figure 13: Smoothing the mesh.

Change Working Dir...

Open geometry file geometry.impeller3.agdb: Click File → Import Model, select a file, click Open, in the menu set units to Millimeter and then click Apply.

Save the project to select project’s name: File → Save Project As..., write mesh_impeller.prj and click Save.

Click Settings → Model/Units in the Main Menu. Set Topo Tolerance to 0.0008 and Triangulation Tolerance to 0.00001, then click OK.

Create the following surface parts (remember, the Surfaces in the Display Tree should be enabled for the selection of the surfaces):

- geom2_in,
- geom2_out,
- geom2_blade_LE,
- geom2_blade_PS,
- geom2_blade_SS,
- geom2_blade_TE,
- geom2_hub,
- geom2_shroud,
- geom2_nowalls_top,
- geom2_nowalls_bottom,
4.2 Computational grid 2

- geom2_per1,
- geom2_per2.

The surface parts are presented in Fig. 14 and Fig. 15. The inlet surface is the one at the largest value of $Z$. The index LE stands for leading edge of the blade (small surface), TE stands for trailing edge of the blade (small surface), the SS is suction side and the PS is pressure side. Hub is the (non-curved) surface at the impeller bottom (at the lowest value of $Z$), whereas shroud are the two curved surfaces opposite to the hub. The top and the bottom surfaces at the largest radius (after the TE), marked geom2_nowalls, do not represent the impeller. They are there just for numerical purposes. Create a body with name BODY_IMPLER.

![Figure 14: Surface parts of the impeller blade.](image1)

![Figure 15: Surface parts of the impeller blade.](image2)

Delete two curves and six points, as presented in Fig. 16. Create part POINTS with all points in the geometry. Create part CURVES that should contain all curves in the geometry.

Set the global mesh setup: in the Main Toolbar click Mesh $\rightarrow$ Global Mesh Setup. Set the global mesh parameters according to Fig. 17 (Max element size=4.0, Tetra edge criterion=0.05, No. of prism layers=1, Rotational period. axis = 0 0 1, angle=60). In addition, in
the Global Prism Settings, set the Number of surface smoothing steps to 0. The height of the channel at the outlet from the impeller is equal to 5.8 mm, which is similar to the maximum size of the mesh element. Therefore, only one prism layer was created, which will be later subdivided into more layers. The tetra edge criterion was decreased to capture the curves of the trailing edge properly (otherwise the trailing edge might become jagged).

The next step is setting parameters of the mesh for the parts. In the Main Toolbar click **Mesh → Part Mesh Setup**: A pop-up window appears. Choose parameters according to Fig. 18 (BODY_IMPELLER part will have a hexa core mesh, max. size=2, prism layers will be located at all walls). The size of the hub, shroud and nowalls parts is 2.5, and remains so for two layers away from the surface (tetra width). To finish, press **Apply**, then **Dismiss**.

The last step of the mesh setup will be a setup of elements sizes on two curves at the trailing edge of the impeller. In the Main Toolbar click **Mesh → Curve Mesh Setup**: For the two curves indicated in Fig. 16 set the parameter 'Number of nodes' to 8. Now the mesh can be computed. In the Main Toolbar click **Mesh → Compute Mesh**: In the Compute Mesh window turn on creation of prism layers and mesh hexa-core after the tetra meshing (Fig. 11). Press **Compute**. At the trailing edge, the mesh will look like as presented in Fig. 12.

Since the prism elements consist of only one layer, we have to subdivide it. In the Main Toolbar click **Edit Mesh → Split Mesh**: Set the parameters according to Fig. 20: Prism Volume Parts=BODY_IMPELLER (click on the icon), No. of layers=5. Click **Apply**. Afterwards, the mesh at the outlet from the impeller will look like as presented in Fig. 13. Note: in general, there should be 10-15 prism layers in the boundary layer due to wall function requirements.

Check the mesh for errors. Click **Edit Mesh → Check Mesh**. Click **Apply**. A pop-up window appears - select the two periodic parts and click **Accept**. Confirm the deletion of unconnected vertices (click **Yes**).

Check the quality of the mesh. Click **Edit Mesh → Display Mesh Quality**. The mesh quality is below 0.2.

Improve the mesh quality. Click **Edit Mesh → Smooth Mesh Globally**. Set the
Figure 17: Global mesh setup for the impeller blade.
4.2 Computational grid 2

Figure 18: Part mesh setup for the impeller blade.

Figure 19: Single layer of prisms. Sharp trailing edge.

Figure 20: Split Prisms setup.
smoothing parameters according to Fig. 13. Click Apply. The step can be repeated with the quality limit set to 0.1, with Prism and Pyramid elements set to ‘Smooth’.

Repeat the previously described Check Mesh step and save the project (click File → Save Project). As in the previous section, export the mesh. Close the project.

### 4.3 Computational grid 3

Start ANSYS ICEM by clicking All programs → ANSYS 16.2 → Meshing → ICEM CFD 16.2.

Set the working directory of the third geometry file (geometry_outlet.stp): File → Change Working Dir…

Open geometry file: Click File → Import Geometry → Legacy → STEP/IGES, select a file, click Open, then click Apply in the window presented in Fig. 4.

Save the project to select project’s name: File → Save Project As…, write mesh_outlet.prj and click Save.

Click Settings → Model in the Main Menu. Set Topo Tolerance to 0.001, Triangulation Tolerance to 0.00001 and units to Millimeters. As for the inlet mesh, scale up the whole geometry by a factor of 1000 (Fig. 6), then rescale the view.

Create the following parts: geom3_in, geom3_out, geom3_top, geom3_bottom, geom3_per1 and geom3_per2. The index LE stands for leading edge, the SS is suction side and the PS is pressure side. The bottom surface is the one at the impeller bottom (at the lowest value of $Z$), whereas the top one is at the largest value of $Z$.

Create a body named BODY_OUTLET.

We will create a blocking for the block-structured mesh, with 40 evenly-distributed nodes in the circumferential direction and 25 nodes in the radial direction. For the height of the ‘channel’ 19 nodes will be used, with spacing 0.1 and ratio 1.3 from both sides. This will result in 19,000-node mesh. In the Main Toolbar click Blocking → Create Blocks . In the window on the left side of the screen (Create Block window) click on the icon $\mathbb{S}$ and press $a$ on the keyboard to select all the geometry. A blocking will appear in the screen (black lines in Fig. 22).

To associate blocking vertices with points click Blocking → Associate in the Main Toolbar. Associate all eight points, as indicated in Fig. 22, by clicking the $\mathbb{E}$ in the Blocking
Figure 22: Blocking (black lines). Associate vertices with points (indicated with similar colours: red to be associated with red, green with green, etc.).

Associations windows in the left side of the screen (use selected radio button Point). To select the vertex, LC in the field Vertex, pick a vertex (LC), then pick a point. To finish use MC.

To associate blocking edges with curves click Blocking → Associate in the Main Toolbar. Then click the in the Blocking Associations windows in the left side of the screen. To select the edge, LC in the field Edge(s), pick an edge (LC+MC), then pick a corresponding curve (LC+MC). To finish use MC. When an edge is associated it turns green (turn off visibility of curves to check it). To check the edge associations, in the Display Tree find Model → Blocking → Edges and right-click Show Association.

To define spacing of mesh elements use Blocking → Pre-Mesh Params in the Main Toolbar, then choose Edge Params icon ( ) in the Pre-Mesh Params window on the left. Do not forget to turn on the tick at Copy Parameters (To All Parallel Edges).

The next step is to take care of the periodicity. Define the 60-degree periodicity, as in the right-hand-side part of the Fig. 9. In the Main Toolbar click Blocking → Edit Block: . In the Edit Block menu on the left, click Periodic Vertices: . Choose (set) the pairs of periodic vertices, as indicated in Fig. 23. The periodicity of vertices, as presented in Fig. 23, can be observed by displaying the vertices in the Display Tree Menu and choosing (RMC on Vertices) Periodic.

Figure 23: Periodic vertices (indicated by red arrows).

Create a pre-mesh: in the Display Tree RC on Pre-mesh under the Blocking tree, then choose Recompute. Turn on the visibility of pre-mesh. By using the blocking parameters described previously, the blocking should look like as in Fig. 24.
Check the pre-mesh quality: click Blocking $\rightarrow$ Pre-Mesh Quality Histograms in the Main Toolbar, choose Quality for the criterion. Click Apply. The result should be close to 1.

Convert the blocking to unstructured mesh (in the Display Tree RC on Pre-mesh under the Blocking tree, then choose Convert to Unstruct Mesh).

Save the project (click File $\rightarrow$ Save Project). Export the mesh. Close the project.
Acknowledgement

This document was created as a result of dissemination during the ACCUSIM project. The ACCUSIM project has received funding from the People Programme (Marie Curie Actions) of the European Union’s Seventh Framework Programme FP7/2007-2013/ under REA grant agreement n°612279.

References